0

I want to use bootstrap theme and it requires jquery 1.9, but when I set 1.9, ajax enabled views do not work. I am using views 3.14. There are few contrib modules which require older version of jquery. So in jquery_update I can set "default drupal" for admin pages and 1.7 for the site.

How to get 1.9 as well for my site with no conflicts?

I have found jquery multi module during search, but do not know if it is what I am looking for.

Secondly, Can I use this module with jquery update enabled?

  • Worth noting that the answer to this can be found on the project page of the jQuery multi module. – rooby May 21 '17 at 6:27
1

Since you need to run multiple versions of jQuery for different contrib modules I would say the jQuery multi module would be the easiest solution (although I don't know the specifics of your requirements).

The 7.x-2.x branch of jQuery update is supported with jQuery multi.

For example, you could use Drupal default jQuery for admin pages, jQuery 1.7 for non-admin pages and jQuery 1.9 for the specific plugins/modules that require it. Or alternatively you can use 1.9 as the main version and 1.7 for specific plugins/modules. Whichever works best for your site.

Usage instructions for the jQuery multi module can be found in its README.txt file when you download it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.