0

By using Drupalgap i create an article and attach/upload an image to that article. Image of name: myimage.jpg has the actual absolute path in website: http://www.example.com/sites/default/files/myimage.jpg. In View(and also in Edit) menu tab inside Drupalgap the image seems to be broken. By debugging i get that in the View it tries to show an image with absolute path of http://www.example.com/sites/default/files/styles/medium/public/myimage.jpg which doesn't exist. What exists in that specific folder is a renamed clone of my image with absolute path http://www.example.com/sites/default/files/styles/medium/public/1495486688801.jpg .
To make things weirder, yesterday's articles created with the same method, which appeared also to be broken yesterday, today are shown just fine. Just fine means that the link of the image being shown points to the correct cloned image: http://www.example.com/sites/default/files/styles/medium/public/1495486688801.jpg .
?q=drupalgap/node/55.json is today's article json with broken links ?q=drupalgap/node/53.json is yesterdays's article json which shows image as expected. Both get 200 OK response. In the 2nd json references the image (...)"filename":"1495486688801.jpg","uri":"public://1495486688801.jpg"(...)
and the 1st as

(...)""filename":"IMG-8a92960d1864691a4e03c9cfe9ee8516-V.jpg","uri":"public://IMG-8a92960d1864691a4e03c9cfe9ee8516-V.jpg"(...).  

Default Display in site uses Large image style and Drupalgap display uses Medium image style for the article node.
I have to mention that the same warning as the issue 776 appears to my log file.
WARNING: drupalgap_remove_page_from_dom() - not removing the current page (node_add_article) from the DOM!
Maybe medium style is not created as per need of my mobile's request.

UPDATE

I installed the imageinfo_cache module and now (confirmed after 3 newly created articles nodes with images) images are not broken in the View menu tab in Drupalgap. But in the Edit menu tab is still broken.

0

It sounds like you need to add this to your settings.php file:

$conf['image_allow_insecure_derivatives'] = TRUE; 
  • @tyler-frankestein I don't think that's the case. I tried your suggestion but doesn't work. Probably nothing to do with Drupalgap, but only with drupal image styles. When i debug it i see in the Edit tab that the broken image url points to a style named ll_media_default.And i don't have such a folder. Here is the exact url link: http://example.com/sites/default/files/styles/ll_media_default/public/image.jpg – roko May 24 '17 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.