6

I've got two Content-Types: Releases, and Scenes.

Releases contain Scenes as Entity reference fields. I would like to link to the Scene Nodes rather than what the current options allow. At the moment my only options for Format under Manage Display are:

  • Label
  • Entity Id
  • Rendered Entity.

These Display:

  • Plain-Text Name of Entity
  • Entity Id #
  • Renders Scene Nodes within Release Node

How can I make Drupal render a link to the Scene Nodes that have been selected in Entity reference fields?

Or, as an alternative, is it possible to display a Teaser instead of rendering the full Scene Node within the Release Node when using "Rendered Entity"?

7

On the Manage Display page for your Releases content type, select "Rendered Entity" for your entity reference field. Then, to the right of the control that contains "Rendered Entity" you will see a little gear. Click on the gear, and you will get another page with a "View mode" control. The view mode has options such as "full content" and "teaser". You can select exactly which view modes appear in this list by going to the Manage Display page for your Scenes content type, and open the "Custom Display Settings" field group. If "Teaser" is not checked, then check it and click "save". After you turn on "Teaser" in this way, you will have a "teaser" button at the top-right if the Manage Display page for your Scenes. Click on this and you can control exactly what appears in a scene teaser. If you want your scene teasers to hold different fields than scenes embedded in releases, then perhaps you could use "tokens" instead of "teaser" for your entity reference view mode.

Edit: Sorry, I only answered the second part of your question. If you want to render just a link to your scene, then select "Label" for your entity reference field, click the gear next to the control again, and turn on the checkbox "Link label to the referenced entity".

  • thank you for yor answers. i find my problem anser with your posts. i try to associate an actor with actor's film teaser views but cant make. when i read your posts i solve the problem. thank you repeat. – user12409 Jan 1 '13 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.