0

I need anonymous users to to be able to se the node teaser but don't allow access to the full content is there a way to do this?

0

To prevent users from access the node you can disable the "View published Content" permission but that will disable it for all node types. If you like to disable it just for one node type you can checkout the content_access module.

You can use a view of content to display the teasers.

In the format section use the format "Unformatted list" and choose your content display Teaser.

If you use a page for the view, you should also check the page access in the page settings section of the view.

I'm not sure if you need the following (It depends on how you prevent the node access):

In the advanced section under query settings you can disable sql-rewriting. This allows you to disable the node_access check. But take attention to this:

"Disabling SQL rewriting will omit all query tags, i. e. disable node access checks as well as override hook_query_alter() implementations in other modules."

2
  • Thank you for your help but this is what I'm trying to do I'm using" Display Suite" for the "search" the search options only gives me 7 options for display none of them is a "view" display that is why I'm trying to make the teaser display for users that are not log in, on other sections of my page I try the option you gave me and it works but unfortunately I can not find a way to add this to the search page. – Daniela aravena Jun 5 '17 at 18:01
  • I'm using Node Option Premium module but is not working for me I install it I check the box to premium content but my teaser doesn't show to anonymous users is there something else I need to mark that I haven't mark to make it work? I'm using the Access Control module as well – Daniela aravena Jun 5 '17 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.