1

I am not able to perform a security upgrade of Drupal core with composer. I get "requirements could not be resolved." Here is my composer.json: https://pastebin.com/KxEQdPkt

Here is the response:

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for symfony/psr-http-message-bridge v0.2 -> satisfiable by symfony/psr-http-message-bridge[v0.2].
    - drupal/core 8.3.2 requires symfony/psr-http-message-bridge ^1.0 -> satisfiable by symfony/psr-http-message-bridge[1.0.x-dev].
    - drupal/core 8.3.3 requires symfony/psr-http-message-bridge ^1.0 -> satisfiable by symfony/psr-http-message-bridge[1.0.x-dev].
    - drupal/core 8.3.x-dev requires symfony/psr-http-message-bridge ^1.0 -> satisfiable by symfony/psr-http-message-bridge[1.0.x-dev].
    - drupal/core 8.4.x-dev requires symfony/psr-http-message-bridge ^1.0 -> satisfiable by symfony/psr-http-message-bridge[1.0.x-dev].
    - Conclusion: don't install symfony/psr-http-message-bridge 1.0.x-dev
    - Installation request for drupal/core ^8.3.2 -> satisfiable by drupal/core[8.3.2, 8.3.3, 8.3.x-dev, 8.4.x-dev].
2

The solution in my case was to delete the vendor directory and delete composer.lock.

I am not totally sure I needed to delete the vendor directory, because I tried that first without deleting composer.lock, and it didn't work. Deleting composer.lock was necessary.

I also changed the minimum-stability to "stable" before deleting vendor and composer.lock, but I doubt that was necessary. In any case, I now have...

"minimum-stability": "stable",

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.