1

I am using the Answers module to configure a discussion feature on our website. The view, which shows the list of questions as well as answers, is only showing questions which have been answers but not unanswered questions, except for admins, who can see all of them. Once the question is clicked, any user can provide an answer.

I cloned, edited and disabled the original view. I've made sure that all authenticated users are able to view published nodes, create questions and add answers.

I've installed this module in a separate sandbox site which is completely stripped to the bare bones and it works as designed, everyone can see all questions.

Customizations I have made to the view include, changing from table to unformatted list format, and bringing in various fields. This screenshot shows the version I created which populates the view with questions and answers, however, this issue was going on before I made that customization. enter image description here

I'm using Answers version 7.x-4.0-rc2

Edit: I have installed this module in a fresh sandbox with no customizations and it works perfectly so I know it's something I broke.

See the exported view. Note "Debugging page" is a simplified version that still has the problem. Please use that page when debugging.

  • 1
    only appearing for admin in D7 logged in users do not get cached content, so something tells me that it might be something to do with your anonymous user cache not clearing. – No Sssweat Jun 14 '17 at 0:05
  • I've cleared caches but this is also a problem for all logged in users except admin - user/1. – Christia Jun 21 '17 at 0:10
  • 1
    check your user role permissions, maybe they are not allowed to see the view pages. – No Sssweat Jun 21 '17 at 0:44
  • 1
    Try giving it an Access value. If still nothing, bulldoze this View and recreate it from scratch. – No Sssweat Jun 21 '17 at 17:35
  • 1
    Hmmmm, a Views-expert like @NoSssweat can't figure it out, so let's see if I can pinpoint your (IMO)- customization error (I might convert my comment to an answer if I succeed later on ...). Question 1: please explain the 2nd (last) filter you're using: it says "(in Answered ...)". While the view shipped with the Answer module has "(= Question)". Also, I QA-tested the rc2-version with the delivered view, which seems to work as expected. Disclosure: I'm a co-maintainer of Answers (you know the drill ...). PS: can you add an export of your custom view (I'd like to experiment with it). – Pierre.Vriens Jun 23 '17 at 11:36
0

Apart from the customizations you described (within your "customizations I have made ..."), you also seem to have customized the 2nd (last) filter that you're using: it says "(in Answered ...)", while in your exported view it shows the machine names of content type "Question" and content type "Answer". While the view shipped with the Answers module (disclosure: I'm a co-maintainer of it) uses ONLY the "Question" content type.

I suggest you adapt that 2nd filter back to how the shipped version looks like, i.e make that filter only check for nodes of content type "Question". And if you then need any other data (columns in your view) specific to the "Answer" content type, those should be made available via the 1st relationship (entity reference) you already have in place (and which still matches the shipped version).

I'm not yet sure if this is the only change you'll need, but at least it will get you closer to the view you're trying to create (depending on possible updates to your question, I might further improve my answer afterwards).

PS: I noticed you also turned of "aggregation" (another customization). Not sure (yet) if that has anything to do with your issue.

0

This issue was solved by taking the advice here and disabling SQL rewriting in the query settings of the view. There is a conflict with some sort of access or workbench module. I haven't been able to pinpoint which one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.