0

I wrote into my settings.php file (into default.settings.php file too):

$conf['theme_debug'] = TRUE;
$settings['theme_debug'] = TRUE;
$settings['theme_auto_reload'] = TRUE;

(These files have 777 permission.)

I have the "Theme developer" module.

I cleared all cache.

But the suggestions doesn't appear.

What else should I do?

(I have Drupal 7.)

3
  • Is this what the documentation for that module says you should do?
    – Kevin
    Jun 15 '17 at 13:51
  • This might sound funny but did you enable the module and its dependencies ? It has a few dependencies from what I recall.
    – dharma
    Jun 15 '17 at 16:37
  • Are you talking about Theme developer? I enabled it.
    – Ayala
    Jun 15 '17 at 17:56
0

People have been facing issues with Theme Developer module. If you installed this module just to get template suggestions, you might want to uninstall it and use theme_debug (only for d7) variable instead.

Enable this variable by adding $conf[theme_debug] to your settings.php or drush vset theme_debug 1

Then Perform a element inspect (or) view page source to get template suggestions. You may find this article on drupal and the answer in this post helpful- self promoting my answer.

1
  • I disabled the Theme Developer. This solved my problem.
    – Ayala
    Jun 20 '17 at 8:22
0

In some installations the minifyhtml module is used. If this is the case, the option “Strip comments from the source HTML” under /admin/config/development/performance/minifyhtml must be deactivated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.