0

I followed the steps on skvare to index Civicrm contacts via Search API, then to have Views list the contacts with the search box as an exposed filter. This seems to work overall, but custom Civicrm fields don't seem to be showing up via Views. For example, I've got records showing up with display name, bio, and contact ID. But they're also supposed to have custom fields called "designation" and "role". I've checked that the corresponding contact created in Civi has values (strings "test" and "pencil sharpener" respectively) for these fields. I've made sure that these fields are indexed in the search API and I've rebuilt the search index, to no avail. I'm able to select the fields in the Views UI but when I look at my View, I don't see them and when I do a dump of the fields variable in the View template, those fields are there but they just have an empty value.

Why are my custom Civi field values empty when I try to display them on contacts indexed with the search API via Views? This is all in Drupal 7.

  • Hi Beth, just to rule this out ... you do have the custom data showing in standard, ie non Search API, views don't you? – petednz - fuzion Jun 19 '17 at 6:42
  • Yes, a view of contacts (rather than a view of indexed contacts) shows these fields. – beth Jun 20 '17 at 22:59
0

Hard to confirm why yours are not showing. If I am comparing like with like then I have built some Views and used Search API to give the custom data in the View columns and to provide blocks showing the count for each of the sub-types of that custom data.

Thing is there is so many steps involved I don't really know how to provide a clear recipe for you to follow assuming of course that would be better thank Mark's since I know I used that as part of my own journey on this.

| improve this answer | |
0

I solved this problem by making sure each field I wanted to use was an indexed field in the Search API settings for my Contacts index, and then re-adding the fields to Views.

| improve this answer | |
  • ah. your Q seemed to imply you had done that: "i''ve made sure that these fields are indexed in the search API" – petednz - fuzion Jun 20 '17 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.