0

I recently installed drupal using git clone option and updated it using composer but I am getting this error I can't fix.

enter image description here

Is there any way to fix this issue? clicking on available updates won't fix the issue. Also, the error related with "LIMITED DATE RANGE" seems mistaken, because I have php7 installed on a 64bit system

0

Since you used git clone, you probably pulled from the HEAD and are running a development version of Drupal. Your Drupal installation does not have an official version number, so it cannot be detected. You can install Drupal with composer, download the zip, or try to clone a tagged release (I always used composer so I am not sure if a tagged release works).

As for the 32/64 bit warning. Depending on the PHP version you have installed, you can run a 32bit PHP installation on a 64bit OS. I suppose that is the root of your problem.

| improve this answer | |
  • Hmm.. I just started creating pages and uploading images. Does changing the core drupal break anything? Can I also even download the core and replace the core I have? It seems dangerous. The only fix I see is wiping out my drupal and installing it again – hidar Jun 20 '17 at 14:03
  • There are two things you can do. Downgrade as you said, this is indeed a bit risky, but if you make a database backup you should always be able to revert to your current version. Or options 2; wait. As soon as the next Drupal release comes, switch to stable and the message should be gone. – Neograph734 Jun 20 '17 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.