1

I'm using drupal server to use the built-in PHP server when building my Drupal 8 site.

I have xdebug set up and I'm using phpstorm. Both work.

The only small issue is that every time I start a debug session, it stops at the .console/router.php file. If I continue on, I get to my actual breakpoint. But I can't figure out how I can bypass this initial break that happens every time.

How can I do that?

3

Go to PHPStorm - Settings

-> Languages & Frameworks

-> PHP

-> Debug

... Section "External connections" -> "Break at first line in PHP scripts" ... disable this option

Additional suggestion:

... Section "Xdebug" -> disable the last two checkboxes

... Section "Advanced settings" -> disable "Notify if debug session was finished without beeing paused"

  • Awesome. Thank you. You're my new favorite person. I upvoted your answer, but I don't have enough cred yet for it to show. – xpersonas Jun 27 '17 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.