0

So i have a couple of nodes I made with the media gallery module. Then made a view called 'most recent photoalbums' with I put inside a block to be displayed on the frontpage. The problem is that characters %5B and %5D are being generated against will and make the links to the nodes not work when clicked. So, hovering over an image in such a view

So with display set as block, everything is left as default except the following: Format:
Show: fields

Fields:
Content: title - nothing fancy here when it comes to settings just linked to node

Content: Gallery media - here obviously is the problem

  • No labels set whatsoever

  • uncheck exclude from display

  • Formatter set to Media
  • File view mode: Preview
  • Multiple field settings fieldset: 'Display all values in same row' checked, Display type: 'unordered list', 'Separator: Display 4 values starting from 0' - 'reversed' unchecked - 'first and last only' unchecked.
  • Style settings fieldset: only 'add default classes' checked.
  • Rewrite settings fieldset (where it's at):
    'Rewrite this output as fied' unchecked,
    'Output this field as link' checked,
    'Link path': node/[title] (I tried all replacement patterns as suggested ),
    'use absolute path' unchecked,
    'Replace spaces with dashes' checked,
    'External server URL' unchecked,

    Transform the case: no transform, all the textfields under

    Link class, title text, rel text, Prefix Text, suffix text and Target are left empty,
    'Trim this field to a maximum length' unchecked,
    'strip html tags' unchecked, under 'preserve certain tags' -> 'remove whitespace' checked, 'Convert newlines to HTML br tags' unchecked.

0

Looks like you probably have spaces in the field [title], try using the nodeid check it works first then come back.

If you have pathauto you could then use this to rewrite the URL to an aliased URL.

0

Since you're rewritting the output of the field as a link the replacement patterns at your disposal won't help you. What I would do is to add the Node Link field to the View and set it as Exlude it from display. Rearrange it on top of the Content: Gallery Media field. Go back and edit the Content: Gallery Media and on the Rewrite settings fieldset you'll see this new Node Link replacement patern. Use that and your links will be fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.