0

I have created a custom taxonomy view. When it is disabled, the taxonomy vocabulary term description shows at the top of the taxonomy page for that term, but when my view is enabled, it does not. How do I include in my taxonomy view the description?

1

Edit your taxonomy vocabulary.

Add the field (or fields) that you want. (Hint: The existing field named "Description" doesn't work, so create a new text-area field if that's what you want. I called my replacement field "Definition".)

From the List tab, edit each term's value for the new field.

Create a new view.

Show: Taxonomy terms of type: your_vocabulary, with a page display

Continue & Edit

Configure the view to display only your new field(s).

Use pager: Display a specified number of items | 1 item

Add a Taxonomy Term contextual filter

Edit the existing Taxonomy Term view.

Click on the "add" button in the Header section

Select Global view type header

Select the new view you created above

Check the "Inherit contextual filters" checkbox

Now when you visit the Taxonomy Term view, your new fields view will be included at the top.

|improve this answer|||||
  • This seems like an excellent answer! I haven't had a chance to try it as my project took me in a different direction but will mark once I've had time to evaluate it. Thank you so much! – Christia Aug 2 '17 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.