-1

Website: http://grausig.info
Drupal version: 8.3.5
PHP: 5.6
Theme: Bartik
Language: only German language installed (to avoid /de/ in URLs)
Modules: only "Tayonomy menu" and "Markdown filter"
Installation: early of 2017 from scratch
Cache rebuild: "drush cr" used all the time after having changed something

I cannot change the Drupal 8 posting date format of articles and book pages into a German format (day before month). It seems to use the "Default medium date". The posting dates at the abstracts on the starting page remain always English (month before day):
http://beginnersmind.de/pics/scrshots/FrontPage.png

But I already changed "Default medium date" into German style such that day comes before month. admin/config/regional/date-time/formats/manage/medium looks good: http://beginnersmind.de/pics/scrshots/DefaultMediumDate.png

But: admin/config/regional/date-time always shows the wrong date pattern by ignoring the modification: http://beginnersmind.de/pics/scrshots/DateAndTime.png
"drush cr" does not help. I always get month before day.

Update: I was able to verify this behaviour with a clean new and empty Drupal 8.3.5 install! Without having the German language installed I am able to edit the English date format. admin/config/regional/date-time shows the configured patterns. However, after having installed and activated German it is not possible to change the date-time format any more. The name of the day turns into German, but the date pattern does no longer reflect the configured state.

Note: The meaning of the date 07/10/2017 depends on the language:
- English: July 10, 2017
- German: Oct 7, 2017
So it is confusing for readers if an English date format is applied to a German text.

Questions:

  1. Did I miss any necessary config action?
  2. Is this a bug?
  • It might be that at some moments Drupal is not completely language aware.... I have issue with translations going wrong as well. Can you switch back to English, remove German, clear caches, re-enable German, go to date settings and set a pattern for each language on the localization tab, or do you already have lots of content? You can configure dates with the UI only. – Neograph734 Jul 11 '17 at 12:51
  • This does not work. If I go back to only English, the patterns on the date and time survey page won't change no matter how I edit them. – Feodor Jul 12 '17 at 15:19
0

I assume this is a bug since the behaviour occurs also at a fresh Drupal installation without any content. A bug report was filed. It contains a step-by-step instruction to reproduce the problem.

Workarounds for mono-lingual sites where the English date pattern won't fit:

  • Modifying twig files which obviously means sub-theming. I am not shure whether this works on non-English sites

  • Leaving the Language module inactive. Date patterns remain editable with the frontend. But e.g. to translate the "submitted by" of posting dates one has to modify node.html.twig which again means subtheming. This works for me.

Edit Oct 11, 2017: The best workaround for non-English monolingual sites known to me and tested by me is: Directly install the target language! Never install English or you may be lost! This can be done with the language selection menu during web install after having loaded the Dupal code. I proceeded as follows to install Drupal 8.4:

  • In the shell: Go to the webroot directory.
  • In the shell: drush dl drupal --drupal-project-rename=directoryname
  • In the shell: cd ./directoryname
  • In the shell: composer install
  • In the browser: call the URL of the site
  • In the browser: follow install instructions and choose your language

Note: As a result the core modules "Configuration Translation" and "Content Translation" were not enabled but "Interface Translation" and "Language" were enabled. It is now possible to edit the date and time patterns.

Note 2: I do not recommend to use "drush site-install"!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.