2

I am getting the following error while installing Drush with composer require drush/drush.

Using version ^8.1 for drush/drush
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- drush/drush 8.1.0 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.1 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.2 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.3 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.4 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.5 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.6 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.7 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.8 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- drush/drush 8.1.9 conflicts with drupal/drupal [No version set (parsed as 1.0.0)].
- Conclusion: don't install drush/drush 8.1.12
- Conclusion: don't install drush/drush 8.1.11
- Conclusion: don't install drush/drush 8.1.10
- Conclusion: don't install drush/drush 8.x-dev
- Installation request for drupal/drupal [No version set (parsed as 1.0.0)] -> satisfiable by drupal/drupal [No version set (parsed as 1.0.0)].
- Conclusion: remove phpdocumentor/reflection-docblock 3.1.1
- Installation request for drush/drush ^8.1 -> satisfiable by drush/drush [8.1.0, 8.1.1, 8.1.10, 8.1.11, 8.1.12, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.8.x-dev, 8.x-dev].
- Conclusion: don't install phpdocumentor/reflection-docblock 3.1.1
- drush/drush 8.8.x-dev requires phpdocumentor/reflection-docblock ^2.0 -> satisfiable by phpdocumentor/reflection-docblock [2.0.0, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.0, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.0a1, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.0a2, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.0a3, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.1, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.2, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.3, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.4, 3.1.1].
- Can only install one of: phpdocumentor/reflection-docblock [2.0.5, 3.1.1].
- Installation request for phpdocumentor/reflection-docblock (locked at 3.1.1) -> satisfiable by phpdocumentor/reflection-docblock [3.1.1].

Installation failed, reverting ./composer.json to its original content.

  • Did you have phpdocumentor/reflection-docblock 3.1.1 already installed in the vendor directory before running composer require drush/drush? Did you run a command similar to composer require phpdocumentor/reflection-docblock 3.1.1, or did you install a package requiring phpdocumentor/reflection-docblock 3.1.1 or any 3.* version? – kiamlaluno Jul 13 '17 at 22:06
  • Also, what command did you use to copy Drupal files? – kiamlaluno Jul 13 '17 at 22:15
3

Had the same problem started from D8.4beta1.

Solved by switching to Drush 9 with:

composer require drush/drush:^9
2

The fix was downgrading phpdocumentor/reflection-docbloc to 2.x with composer require phpdocumentor/reflection-docblock:^2.0.

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 1 update, 0 removals
- Installing dflydev/markdown (v1.0.3): Downloading (100%)
Drupal\Core\Composer\Composer::vendorTestCodeCleanup
- Updating phpdocumentor/reflection-docblock (3.1.1 => 2.0.0): Downloading (100%)
Drupal\Core\Composer\Composer::vendorTestCodeCleanup
Package dflydev/markdown is abandoned, you should avoid using it. Use michelf/php-markdown instead.
Writing lock file
Generating autoload files
Drupal\Core\Composer\Composer::preAutoloadDump
Drupal\Core\Composer\Composer::ensureHtaccess

Then install Drush with composer require drush/drush.

Using version ^8.1 for drush/drush
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 12 installs, 0 updates, 0 removals

2

I was able to reproduce the error, using the following commands:

composer create-project drupal/drupal 8 ^8.3
cd 8
composer update
composer require drush/drush

The last command gave the following output.

Using version ^8.1 for drush/drush
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- drush/drush 8.1.0 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.1 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.2 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.3 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.4 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.5 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.6 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.7 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.8 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- drush/drush 8.1.9 conflicts with drupal/drupal[No version set (parsed as 1.0.0)].
- Conclusion: don't install drush/drush 8.1.12
- Conclusion: don't install drush/drush 8.1.11
- Conclusion: don't install drush/drush 8.1.10
- Conclusion: don't install drush/drush 8.x-dev
- Installation request for drupal/drupal No version set (parsed as 1.0.0) -> satisfiable by drupal/drupal[No version set (parsed as 1.0.0)].
- Conclusion: remove phpdocumentor/reflection-docblock 3.2.0
- Installation request for drush/drush ^8.1 -> satisfiable by drush/drush[8.1.0, 8.1.1, 8.1.10, 8.1.11, 8.1.12, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.8.x-dev, 8.x-dev].
- Conclusion: don't install phpdocumentor/reflection-docblock 3.2.0
- drush/drush 8.8.x-dev requires phpdocumentor/reflection-docblock ^2.0 -> satisfiable by phpdocumentor/reflection-docblock[2.0.0, 2.0.0a1, 2.0.0a2, 2.0.0a3, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.0, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.0a1, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.0a2, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.0a3, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.1, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.2, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.3, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.4, 3.2.0].
- Can only install one of: phpdocumentor/reflection-docblock[2.0.5, 3.2.0].
- Installation request for phpdocumentor/reflection-docblock (locked at 3.2.0) -> satisfiable by phpdocumentor/reflection-docblock[3.2.0].

Installation failed, reverting ./composer.json to its original content.

In fact, composer update output the following (among other lines):

  • Updating phpdocumentor/reflection-docblock (2.0.4 => 3.2.0): Downloading (100%)

I tried also using composer require drush/drush dev-master and/or composer create-project drupal/drupal 8 8.4.*@dev but all the combinations caused the same error messages.

I was able to install Drush 8.1 with Drupal 8.3 using the following commands.

composer create-project drupal/drupal 8 ^8.3
cd 8
composer require drush/drush
composer update

In this case, Composer doesn't install anymore phpdocumentor/reflection-docblock 3.2.0, but 2.0.5.

  • Updating phpdocumentor/reflection-docblock (2.0.4 => 2.0.5): Downloading (100%)

drush status outputs the following.

 Drupal version         :  8.3.5
 PHP executable         :  /usr/bin/php
 PHP configuration      :  /etc/php/7.1/cli/php.ini
 PHP OS                 :  Linux
 Drush script           :  /home/kiamlaluno/8/vendor/drush/drush/drush.php
 Drush version          :  8.1.12
 Drush temp directory   :  /tmp
 Drush configuration    :
 Drush alias files      :
 Drupal root            :  /home/kiamlaluno/8
 Drupal Settings File   :  MISSING
0

I think easy way is via

composer install
composer require drush/drush

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.