0

I have an image field inside a field collection (set to unlimited). After selecting the file to upload and clicking Upload the field reverts back to 'No file selected'.

There is nothing in the Drupal or Apache logs and there are no JS errors.

Even stranger, this works on my local dev environment but not on staging server. I have set PHP config to mirror local but again, still not working.

Image field appears to work okay when not in a field collection.

Absolutely no idea what this could be?! Only other difference I can see is PHP version on local is 5.6 and on staging is 5.5 but not sure why this would cause a problem.

EDIT: This is a field collection inside a field collection. An image field nested in a field collection does work.

0

1) Check if your web-server has read/write access to sites/default/files(typically uploaded files go here).

2) Other reason might be the file you're trying to upload is bigger than allowed. Increase max-allowed upload file-size in .htaccess file

php_value upload_max_filesize  "20M"
  • Thanks @dharma - Yes, should have mentioned file perms are all okay and php file size value is sufficient enough. Still not working. – digitaldots Jul 12 '17 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.