I have a view with exposed filters "status" already set default to "ready". The view filters are exposed in a block.

When I first open the view page, the status "ready" is ignored and it only applies the filter when I click on the "Submit" button in the exposed form.

I want the status "ready" to be applied when I open the view page. This works great if the filters are not in an exposed block... but I need them to be...

What can I do?

  • Did you find a solution to this? I have a similar issue. Apply/Reset does not work initially but it starts to work when I use the pagination. I typed this in console (Drupal.views.instances) and noticed that exposedAjaxForm is missing initially. – Abdul Sadik Yalcin Dec 22 '17 at 13:36

Download and enable Better Exposed Filters. You should find a new setting under Exposed Form, in BEF Settings check "Autosubmit" and that might solve your problem. enter image description here

  • Hi, thank you for your answer. Autosubmit is not a solution, I really need the submit button. – user2993623 Jul 13 '17 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.