2

I am using drupal 7.54 and I am a bit in trouble.

I have made a multilingual website based on entity translation.

I created a custom content type that users can create or edit nodes with. And that content type has a language field.

But in that dropdown field, English shows first in both languages. It confuses french users. So I need to make the current language the first on the list of languages. As an example I want the list to display like this

  • Français
  • Anglais

when viewing the site in French version. And :

  • English
  • French

when viewing the site in English.

Hopefully I explained the problem properly, I'll be very happy to know what to do.

I need help please.

1

If you edit your content type, you should have a Language settings tab, I guess you have on Default Language "Site's default" and not the current interface language.

  • Thank you so much. It did work. I went to "multilingual setting" -> Set custom language as default for new content and let "Custom default language" at "current language". It work!!!!!! – mosgeorges Aug 1 '17 at 15:40
  • Np, don't hesitate to accept the answer if it solves your problem and can help future viewers. – guilhom Aug 1 '17 at 17:13
  • @mosgeorges Please have a look at this ... it explains what "you" are expected to do if you get an answer to a question that did help you (and/or actually solved your issue). for short, as per your prior comments, it appears to me that at least you should mark this answer as accepted, similar to hat is also suggested in the prior comment (if you do, you'll receive another small surprise yourself also ... aka +2 rep points). And BTW, do not hesitate to also upvote it if you want to do so ... like I just did also .. – Pierre.Vriens Aug 11 '17 at 13:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.