0

I have path aliasing, which gets the path from the title of the News article, working fine.

However, in the Google index, I noticed that the canonical URL for nodes is working as well. So, Google is indexing the node pages twice: with the canonical URL and with the path alias.

I want to disable the canonical URL for nodes, so I tried installing the node_page_disable module. It installed fine, and I enabled it with Drupal 6.

In http://www.example.com/admin/settings/site-information, there is a Default front page textbox, which by default contains node. If I remove node from the textbox, and save the settings, Drupal complains with:

Default front page field is required.

The module I installed adds a Retain /node as an active url? checkbox. If I click on that, I am required to remove node from the Default front page textbox.

How can I do it, since removing node causes Drupal to complain about a required value not given?

1

You must give a value for Default front page, and since you don't want to use node, you need to give another value for that setting.

  • Enable the Path module that comes with Drupal 6 core, from admin/build/modules

    screenshot

  • Create a Page node, from node/add

    screenshot

  • Add the path alias you want to use to the node being created

    screenshot

  • Save it

  • Change the default front page, and put the path alias you assigned to the node you just created, on admin/settings/site-information

    screenshot

  • Save the settings

Now Drupal will use that node as front page.

screenshot

If you installed the Vertical tabs module, the node edit page would appear different. In this case, you can find the path alias text-box under the URL path settings tab.

screenshot

I used a Page node for the front page, but you can use any content type you want.

0

Actually I used the Global redirect module to fix this. Here is the guide:

http://www.zyxware.com/articles/3571/solved-drupal-pathauto-google-is-indexing-node-urls-instead-of-url-aliases

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.