1

I've installed Drupal 8 via Softaculous, and after I logged in for the first time, I see a message:

TRUSTED HOST SETTINGS Not enabled The trusted_host_patterns setting is not configured in settings.php. This can lead to security vulnerabilities. It is highly recommended that you configure this. See Protecting against HTTP HOST Header attacks for more information.

I edit /drupal-install-dir/sites/default/settings.php and add:

$settings['trusted_host_patterns'] = [
  '^smith\.technology8\.com$',
];

in order to make smith.technology8.com a trusted site.

However, after upload of /drupal-install-dir/sites/default/settings.php and refreshing the admin page, the original error remains.

Is there something more I need to do, or is my addition to settings.php incorrect?

Thanks.

  • Have you tried clearing the cache? – Neograph734 Aug 3 '17 at 8:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.