2

In addition to the Drupal Commerce module, I installed the Commerce Message module for Drupal 7. Everything works fine so far.

I created a new Rule to send a billing e-mail in addition to the order completed e-mail to the customer.

But now I have the problem that I can not apply any tokens that give me the address or full name of the customer. It seems, that the standard Drupal Commerce tokens do not work in the Commerce Message module.

I looked through the files of Commerce Message and I can only find a few tokens that do not help at all.

According to law I need to send billing information to the customer. Including the customer's full name and address.

How can I use the Drupal Commerce standard tokens with Commerce Message?

Also despite saying that it would be able to use multiple html tags it does not. Whenever I use <em> (for example: <em>italic</em>) it does not include such <em> in the e-mail (for example: it only includes /italic/).

Any help?

2

Even though your question is about the "Commerce Message" module, at its core your question relates to the Message module. And since you are using the Rules module, you can make the missing tokens (= the commerce standard tokens, as in your question ...) available by using the Replacement patterns for each message type.

So the answer to your question is "Whatever token you're missing, just make it available via Rules, by creating a replacement token for them". Refer to the answer to What's the purpose of "Replacement tokens" of a Message type? for way more details on that.

These Replacement tokens are really a hidden gem about how Rules integrates with Message. For an example to see them at work, refer to my answer to "Which user related token(s) can be used to create a Rule for setting up a message type?".

0

About this part of your question (near the end):

... use multiple html tags ...

That's really a different question, so here is a separated answer to that also: it must be that for the "Message text" you're using, you're using an HTML filter in which the <em> tag is not allowed (yet). So make sure to use an HTML filter in which it is allowed.

  • The strange things is that I use FULL HTML Filter for that. It just doesn't seem to be the filter that is applied. For now I used a workaround concerning the html problem. – Dantalion Aug 9 '17 at 1:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.