0

I have a D7 site running in a Vagrant VM.

I was getting the following error when attempting to run drush updb from the site folder:

Command updatedb needs a higher bootstrap level to run - you will need to invoke drush from a more functional Drupal environment to run this command.

The drush command 'updb' could not be executed.

I simply couldn't figure out why this won't run, so I thought I'd update drush. It was on 8.0.0-rc4.

I updated via composer on my local machine, and when I type drush --version it shows 8.1.12.

But, when I run drush status it still shows 8.0.0-rc4, and to top it off, I still cannot run drush updb

What is going on here?

I have tried running drush --uri=mysite.local updb but that doesn't help either.

0

In Vagrant, you need to SSH to the machine and run Drush from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.