0

I'm using Drupal 8 and I'm trying to install the varbase distribution from the command line, on Windows with Acquia Dev Desktop.

The steps I did are:

  • Disable opcache
  • Check composer -V >>> result
  • Run composer create-project Vardot/varbase-build:^8.4.06 %1 --no-dev --ignore-platform-reqs

This is causing the following error:

  • Installing vardot/varbase (8.4.06): Downloading (100%)
    Writing lock file
    Generating autoload files
    PHP Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in C:\www\tmp_var\vendor\drupal-composer\drupal-scaffold\src\PrestissimoFileFetcher.php on line 34
    Parse error: syntax error, unexpected 'class' (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or '{' or '$' in C:\www\tmp_var\vendor\drupal-composer\drupal-scaffold\src\PrestissimoFileFetcher.php on line 34

I installed composor on windows Url: https://getcomposer.org/download/

(This is besided the compososer which is included in Acuia Desktop Version 2)

C:\www>composer self-update
You are already using composer version 1.5.1 (stable channel).

Then I exectuted commando:

composer create-project Vardot/varbase-project:^8.4.07 varbaseyellowbird --no-dev >> installlog.txt

After running it my project drupal folder was not looking good so I runned it again.

2

Drupal 8 requires PHP 5.5.9 or greater. The error is informing you that you have a lower version than that installed; specifically that the functionality for obtaining class name using ::class, which was added in 5.5, is missing.

The solution is to upgrade PHP to a version that Drupal supports.

  • In acuqia desktop, php 5.6.30 is included.... – Justme Aug 16 '17 at 10:21
  • ok running php.exe response indeed with low version. – Justme Aug 16 '17 at 10:26
  • What VM/Acquia/etc has, vs what the CLI uses can be two different things. For Windows, you might want to swap out to DrupalVM, which currently supports up to 7.1. – Kevin Aug 16 '17 at 13:34
0

PHP must be 5.6

Warning: About composer

https://getcomposer.org/download/

As we dedicated that composer had 3 changes updates under 10 days

1.5.1 (2017-08-09) 1.5.0 (2017-08-08) 1.4.3 (2017-08-06) 1.4.2 (2017-05-17) 1.4.1 (2017-03-10)

Which composer version are you using?!

After updating the composer:

   $ sudo composer self-update 1.5.1

You could use:

$ composer create-project Vardot/varbase-project:^8.4.06 PROJECT_DIR_NAME --no-dev --no-interaction

or

$ composer create-project Vardot/varbase-project:^8.4.07 PROJECT_DIR_NAME --no-dev --no-interaction

As we started to use Vardot/varbase-project from varbase 8.4.06

To read more https://www.drupal.org/node/2903606

  • I installled composer in windows besided acquia desktop. I updated the question.... I still not gettting varbase to run... – Justme Sep 3 '17 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.