0

I have a DateTime field in a content type. I set the value as 00:00:00 for the H:m:s. My timezone is set to Europe/Bucharest. Whenever I get the field the value changes to 21:00:00.

Obviously Drupal is adjusting to fit my timezone. I assume, I'm not sure.

I don't want any sort of adjustments to be made. I want the time I've entered.

How can I get the non-adjusted time or disable Drupal adjusting the time?

0

I am not sure if you can disable it completely, but by changing the site's default timezone to the same timezone as your server, and preventing users from setting their own timezone you should be good.

Both can be configured on /admin/config/regional/settings

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.