0

I'm recently getting the error below:

HTTP error 0 occurred when trying to fetch https://ftp.drupal.org/files/projects/captcha-7.x-1.5.tar.gz. Downloading updates failed:

Failed to download captcha from https://ftp.drupal.org/files/projects/captcha-7.x-1.5.tar.gz

Blockquote

I'm running my website on a shared platform, so I can't change the parameters of PHP...

Based on this long thread drupal dot org/node/247009 I have already tried several many potential solution with no luck so far. This is what I tried and it did not work:

  1. gave 777 recursive permissions to tmp and site/default/
  2. tried on different browsers (Edge, Firefox, Chrome)
  3. in jquery update module I changed the jquery default version to 1.10
  4. I set the jquery source from google, and I set the jquery to non-minified
  5. I checked and in settings.php I do not have any base url set
  6. the file which failes to be downloaded is very small in size 103KB, so I guess it's not about uploading to large files
  7. I checked my PHP version and it did not change recently it;s 5.3.29
  8. I also checked the PHP memory limit and it's set to 256MB which to me it's not that low for uploading a 103KB file
  9. I I tried the update of a different module, and I get the same error

What could be the problem? Where to look next?

4
  • Random question, but you don't have a module called HTTPRL enabled do you? I had issues where that used to interfere with retrieving update notifications for modules.
    – Kevin
    Sep 11 '17 at 21:00
  • Hi, I don't have the HTTPRL module :(
    – Koy
    Sep 12 '17 at 16:29
  • PHP 5.3 received its last security update 3 years ago. You should consider updating to a supported version. Sep 12 '17 at 18:34
  • Thank you Neograph734, but I'm running on a shared hosting service so can't upgrade bymyself. I see your point though. I have retried to update the captha module and it's the same problem. Any other ideas would be appreciated. Kevin was asking me about a specific module, could it be because of another module? I had all the modules before as well, so why now to get broken? I did not install a new module for quite some time (it could be even one year) and in the meantime I have updated many other modules...
    – Koy
    Sep 12 '17 at 18:53
0

I had the exact same problem and the solution given by Neograph734 was to manually add the module. If you have Filezilla, connect to your drupal site files. Go to Sites-->all--->modules---> Locate the captcha folder, delete everything in that folder. Upload the updated captcha module files. (Download and upzip first).

Once this is done, you will also need to update the database. It will show you where to do that once you click on reports. Once the database is updated, your module should now be upgraded and working. :)

No more nasty notices about having to upgrade it!

Not the answer you're looking for? Browse other questions tagged or ask your own question.