0

Where testing the migration from drupal 7 to drupal 8 and everything almost works, except i'm running into a language problem.

I have two different languages enabled in Drupal 7, English(Default) and Dutch, but only for the interface, there is no multi-language setup for nodes.

Now, when i imported the content in drupal 8 with the same two languages enabled, i get to see the content, but it is dived between three types:

  • Not specified
  • Dutch
  • English

I want to see all the content without selecting a language(via url, session, ..). So, how do change it so i can view my nodes without a language prefix in the url ?

I already tried messing with the database and changing the 'langcode' to 'und' and that works, but it breaks many other things. I just want to see site.tld/my-cool-url-alias without anything else.

0

You need to change your language selection criteria in this admin setting:

Admin -> Configuration -> Regional & Language -> Language / Detection and Selection Tab

You can turn off or configure the URL settings as you want. With no standard detection, the default language should be shown.

You probably want to turn on the administration language detection option. This allows admin users to select their preferred admin language.

  • That does not help in my case, but i found a module that does exactly what i need; drupal.org/project/neutral_paths ; with this module, people can access all the content, Independent from the 'node language". This is not a solution for everybody, but it does work in my case.. – user1064293 Sep 13 '17 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.