I am getting the following error in a Drupal 8 site.

The following module is missing from the file system

It looks as if a custom module was installed and deleted without uninstalling it.

How can I fix this error?

  • Are you using the configuration management in the site? Commented Sep 12, 2017 at 20:06
  • Yes I am using that
    – Kevin
    Commented Sep 12, 2017 at 20:09
  • Some advance with the problem? I want to know at the end how do you solve the problem, this can arrive me too in any project. Commented Sep 15, 2017 at 16:34
  • In Drupal 8.7.3 I am getting "following module is missing from the file system: php in drupal_get_filename()" but when I try install the php module I get an error about it already existing in core. The error is preventing me from uninstalling anything. Yesterday I upgraded to 8.7.3 and today to 8.5.3 and cannot shake the error. Cache has been cleared each time and all modules that I know about have been restored. I see notes about Drush but how to install it on 8.7.3?
    – WilliamK
    Commented Jun 6, 2019 at 3:20

6 Answers 6


Drush 9

drush cdel core.extension module.MYMODULE
  • 2
    Thanks for the answer. It might be helpful to add a bit more explanation about config:delete and maybe use config:delete rather than the cryptic cdel. I think this also works for Drush 10.
    – mradcliffe
    Commented Jul 29, 2021 at 20:08
  • Worked for me on a Drupal 9 instance.
    – lchabrand
    Commented Sep 1, 2021 at 6:55
  • This actually worked for me on a drupal 8.8 migration. Ty!
    – G_Style
    Commented Mar 15, 2022 at 15:26
  • worked for me on d Drupal 10 instance!
    – zhouji
    Commented Jan 31 at 1:28

Assuming you have deleted an unimportant custom module which doesn't need any uninstall routine to be triggered, you can use the following Drush command.

  • Drupal 7

    drush sql-query "DELETE from system where type = 'module' AND name = 'MYMODULE';"
  • Drupal 8

    drush sql-query "DELETE FROM key_value WHERE collection='system.schema' AND name='MYMODULE';"

See How to fix "The following module is missing from the file system..." warning messages for more info and alternatives.

  • 1
    I tried few times and this for D8 doesnt work at least for d8.7. I would recommend solution below with generating dummy module and then uinstalling.
    – Blissful
    Commented Jun 23, 2019 at 8:22
  • The Drupal 8 command worked for me for a Drupal 9.3.9 upgrade from 8.
    – G_Style
    Commented Apr 1, 2022 at 15:26

If you have Drupal Console then a quick way to fix this is to generate a module with the same machine name, then uninstall it.

$ drupal generate:module

Then type the machine name at the appropriate prompt and accepts defaults for everything else.

$ drush pm-uninstall

Then you can delete the newly generated module from the file system and continue with your day.

(NB you may find need to keep that generated module, else the error will return. In that case, if you need to install a contrib module with the same name, remove the generated module after adding the contrib module. Then clear the cache.)

  • 2
    This was the simplest option after the SQL query above wouldn't work. Commented Oct 19, 2018 at 17:36
  • It helped to resolve my error for module not found. Commented Dec 11, 2019 at 14:36
  • If anyone needs help installing Drupal Console, I found this page helpful. Bear in mind, you'll want to install the Drupal Console Launcher globally, AND the Drupal Console locally (in the project root of your Drupal install).
    – Doomd
    Commented Apr 23, 2020 at 1:44

The way I fixed it was by using drush and composer. Get the module with require, install and uninstall with drush then remove with composer.

composer require drupal/missing_module
drush en missing_module
drush pmu missing_module
composer remove drupal/missing_module

! The step with drush en probably is not nessesary


Now with the Configuration Management module the modules configuration is stored in the core.extension.yml file.

Go to edit the file and try to find the missing module from the filesystem then delete the line and import the config (drush cim).

If this not works but you has found the module, then create the module again (just the folder and a valid .info.yml file) and run again the drush cim command. This will uninstall the module.

  • 4
    This works, but the correct way is to restore the module and uninstall it. If that module provides schemas, configuration or so, it will remain in the system and you will have to clean it up manually otherwise.
    – Berdir
    Commented Sep 13, 2017 at 6:19
  • 1
    @Berdir if you can't find the custom module, we can do another thing? Commented Sep 13, 2017 at 13:01
  • Not really, then you need to do it manually as suggested above with drush cedit or import/export in the core.extension file.
    – Berdir
    Commented Sep 13, 2017 at 13:18

if you know exactely what you're doing and can't use a cleaner method from https://www.drupal.org/docs/updating-drupal/troubleshooting-database-updates

here is a suggestion :

drush php:eval '\Drupal::configFactory()->getEditable("core.extension")->clear("module.MY_MODULE_THAT_BREAKS_THINGS")->save(TRUE);'
drush cr
  • 4
    If you're going to use drush, why do this instead of config:delete?
    – anonymous
    Commented Jul 29, 2021 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.