2

I am creating a basic page having some text links as follows:

http://localhost:8080/student
http://localhost:8080
http://localhost:8080/login

D8 automatically converts this text URL to links as follows

http://localhost:8080/sutdent

http://localhost:8080

http://localhost:8080/login

I don't want to convert the text URLs to links. I also checked the text filters but did not work for me. enter image description here How to prevent this conversion?

  • If this is the body od the node then a) the input filter for converting links is active or b) yo uare using wysiwyg(ckeditor) and it converts is on its own(or c) you are pasting it as link instead of text). – user21641 Sep 16 '17 at 9:56
  • @IvanJaros I'm passing URL as text not link.. – Sunil S Sep 16 '17 at 10:17
  • When editing the node, do you have correct input filter selected? Also, isn't the content already saved? Meaning the link is already in the db? Try creating a new node or edit the soruce code directly(if you have ckeditor). – user21641 Sep 16 '17 at 11:18
  • Filters in text formats are used to format output. Cache needs to be cleared too after re-configuring text formats. I don't think the Cache context is invalidated when the text format changes... – mradcliffe Sep 16 '17 at 12:54
1

As far as I know this is not a problem if you a using CKeditor.

I tried to write some text URLs in both Basic HTML and Full HTML format. It worked fine, if you want to see how I did I have made a little video for you:

https://vimeo.com/234845994

  • I have tried this on a fresh drupal 8 installation and it works fine ☺ – user72672 Sep 21 '17 at 7:41
  • 1
    I need full HTML format.. – Sunil S Sep 21 '17 at 9:40
  • Ok try to write the link text and then change the a tags to p tags in the source code and see if that works. – user72672 Sep 21 '17 at 10:00
0

I had the same problem in D7. Not sure if it's related. I am not exactly sure what fixed it but I did completely uninstall and them re-install filter_module. I also had to restart apache to clear out some caching there.

All my settings were like yours with convert URLS to links disabled. Did not matter what text format or WYSIWYG editor I used. I always cleared Drupal cache after making changes and used browser in incognito mode to make sure there was no caching.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.