2

I have a content type in D8 that requires translation, however at the moment I appear to be only able to translate the individual fields and not the title.

Title says all languages

The language selector is available on the content type edit page, but there seems to be no way of selecting to translate the title:

Language selector

Other fields have a checkbox that allows them to be translatable:

enter image description here

Any ideas? Thanks in advance!

2
  • 1
    The title is set as translatable by default (in the entity definition). Somehow you've disabled translation for this field. You can check the translatable fields for all content types here: /admin/config/regional/content-language
    – 4uk4
    Commented Sep 26, 2017 at 11:44
  • Ah yes, that's the one! I don't think anyone has actively turned it off, it's a site in alpha build at the moment..! If you post this as an answer, I'll accept. Thanks! Commented Sep 26, 2017 at 13:39

1 Answer 1

4

The title is set as translatable by default (in the entity definition). Somehow you've disabled translation for this field. You can check the translatable fields for content entities here:

/admin/config/regional/content-language

This includes all fields, also the base fields, which you can't configure in Manage Fields of the content type.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.