1

After installing the WYSIWYG module + CKEditor / TinyMCE (same result) all my paragraphs are blown away resulting in an uneditable mess. Can you give me a clue how to make it read my paragraph markup? Thanks

enter image description here

  • this happens because you actually have no paragraphs. before of ckeditor, your paragraphs were just some <new lines>, not actually an html paragraph. The CKEditor gets your text and because it can't find any html markup it makes your text look like the one in your image. – Marius Ilie Mar 6 '12 at 15:29
5

I had the same problem and I solved it by allowing paragraph and line break in the configuration of the Filtered HTML:

Configuration » Content authoring » Text formats » Filtered HTML

In the "Allowed HTML tags" of the "Filter settings" I added <p> and <br>

| improve this answer | |
2

To solve that, you should make the CKEditor disabled by default. Then when you edit an page, Copy the existing text, enable the editor and Paste the text. Now you'll have well formatted html text.

Or you could try Wysiwyg Linebreaks module, it should do the job. I never tried it but maybe you'll be lucky :)

| improve this answer | |
  • I used Wysiwyg Linebreaks but won't work. Thanks Marius I will try out your tip. – drupal_stuff_alter Mar 7 '12 at 11:27
  • I have a mix of markup & linebreaks in a site I'm migrating and the wysiwyg + ckeditor + wysiwyg linebreaks combo is working for me. Before the linebreaks module I was losing existing formatting as per @Marius's comment above. So props to you Marius! – Merrick May 9 '12 at 4:43
1

Try configuring appropriate CKEditor profile (it's in Config > Content Authoring, I believe). There you have settings as per what should be done with paragraphs and empty lines. Also make sure you allow p elements in your Full or Filtered HTML - but that's controlled outside of CKEditor.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.