0

When you download the source from here, and run composer:

php composer.phar require facebook/graph-sdk

I get:

    You are running Composer with SSL/TLS protection disabled.
Using version ^5.6 for facebook/graph-sdk
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.4
9m

  Problem 1
    - Conclusion: don't install symfony/http-kernel v2.8.27
    - ...
    - Conclusion: don't install symfony/http-kernel v2.8.5
    - Conclusion: remove symfony/http-kernel v2.8.4
    - Conclusion: don't install symfony/http-kernel v2.8.4
    - ...
    - Installation request for symfony/http-kernel ~2.8 -> satisfiable by symfony/http-kernel[2.8.x-dev, v2.8.0, v2.8.0-BETA1, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - Conclusion: don't install symfony/debug v3.0.9
    - symfony/http-kernel 2.8.x-dev requires symfony/debug ^2.6.2 -> satisfiable by symfony/debug[v2.7.6, 2.6.x-dev, 2.7.x-dev, 2.8.x-dev, v2.6.10, v2.6.11, v2.6.12, v2.6.13, v2.6.2, v2.6.3, v2.6.4, v2.6.5, v2.6.6, v2.6.7, v2.6.8, v2.6.9, v2.7.0, v2.7.0-BETA1, v2.7.0-BETA2, v2.7.1, v2.7.10, v2.7.11, v2.7.12, v2.7.13, v2.7.14, v2.7.15, v2.7.16, v2.7.17, v2.7.18, v2.7.19, v2.7.2, v2.7.20, v2.7.21, v2.7.22, v2.7.23, v2.7.24, v2.7.25, v2.7.26, v2.7.27, v2.7.28, v2.7.29, v2.7.3, v2.7.30, v2.7.31, v2.7.32, v2.7.33, v2.7.34, v2.7.4, v2.7.5, v2.7.7, v2.7.8, v2.7.9, v2.8.0, v2.8.0-BETA1, v2.8.1, v2.8.10, v2.8.11, v2.8.12, v2.8.13, v2.8.14, v2.8.15, v2.8.16, v2.8.17, v2.8.18, v2.8.19, v2.8.2, v2.8.20, v2.8.21, v2.8.22, v2.8.23, v2.8.24, v2.8.25, v2.8.26, v2.8.27, v2.8.3, v2.8.4, v2.8.5, v2.8.6, v2.8.7, v2.8.8, v2.8.9].
    - Can only install one of: symfony/debug[v3.0.9, v2.7.6].
    - ...
    - Can only install one of: symfony/debug[v2.8.9, v3.0.9].
    - Installation request for symfony/debug (locked at v3.0.9) -> satisfiable by symfony/debug[v3.0.9].

Installation failed, reverting ./composer.json to its original content.

Surely the core composer file that comes with Drupal can work with the facebook SDK. What am I missing?

  • Did you definitely take no other steps? I just downloaded Drupal from the link above, immediately ran composer require facebook/graph-sdk, and it worked fine – Clive Sep 30 '17 at 17:21
  • I found the issue. I was using composer.json file from an older version. I always update /core, but not composer.json. facepalm – coderama Sep 30 '17 at 17:22
  • 3
    It happens ;) In case you're not aware of it, try out the Drupal project. It'll change your workflow slightly, but it'll be much harder to run into a similar problem as you can manage your core updates with composer. And, perhaps more importantly, your custom packages will be managed in a separate composer.json to the core one, so you won't need to consider Drupal's any more – Clive Sep 30 '17 at 17:25
  • Yep. One of the biggest barriers to composer adoption strikes again. Check out the non d.o tar balls for composer project management. – Kevin Sep 30 '17 at 18:28
2

Hope it helps someone else. The issue was that I only updated drupal's /core folder, not composer.json. So I had a very old composer file. When I updated it with the composer.json from the latest D8 download, things started working again.

1

This likely to be not related to facebook/graph-sdk, since it doesn't require any symfony related packages as per:

composer show facebook/graph-sdk ^5.6

The error happens during update of your dependencies where your existing symfony/debug package is locked at v3.0.9 (as per your composer.lock) and another package requires ^2.6.2 and you are able to install one branch within same vendor dir.

To find out which existing packages requiring symfony/debug, run:

composer why symfony/debug -t

I had similar issue when I've tried to install drush/drush ~8@stable and drupal/console-core 1.8.0 in the same folder and it failed due to incompatible dependencies. I've reported this issue at hechoendrupal/drupal-console-core (GH-338).

Related posts:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.