When a user submits a webform submission, they get redirected to a confirmation page, in my case its node/40. Now if they also have to click on an email confirmation link, it also sends them to the same confirmation url node/40.

How can you set a different confirmation url for the one in the email?

enter image description here

  • How's the e-mail confirmation link being sent? custom module? or...
    – No Sssweat
    Commented Oct 3, 2017 at 23:49
  • Its being sent via the webform Confirmation request emails (always send) page. This page: prntscr.com/gsyno2 Commented Oct 4, 2017 at 0:08
  • 2
    nevermind! i found it... there's another field for another url on that page. didn't see it. Commented Oct 4, 2017 at 0:39
  • 1
    @duckx If you found the answer, please write a brief answer so that it's clear your problem is solved. Commented Oct 4, 2017 at 4:26

1 Answer 1


There is actually a Set the redirect URL field in the "confirmation" email page setting which i totally missed. See below:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.