2

when I do an update with "Composer", the following error is displayed :

www.s1biose.com@vps000000:~/public_html$ composer update

Cannot create cache directory /home/www.s1biose.com/.composer/cache/repo/https---packages.drupal.org-8/, or directory is not writable. Proceeding without cache
Cannot create cache directory /home/www.s1biose.com/.composer/cache/repo/https---packagist.org/, or directory is not writable. Proceeding without cache
Cannot create cache directory /home/www.s1biose.com/.composer/cache/files/, or directory is not writable. Proceeding without cache
Gathering patches for root package.
> DrupalProject\composer\ScriptHandler::checkComposerVersion
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install drupal/core 8.4.0-rc2
    - Conclusion: don't install drupal/core 8.4.0-rc1
    - Conclusion: don't install drupal/core 8.4.0-beta1
    - Conclusion: don't install drupal/core 8.4.0-alpha1|remove symfony/event-dispatcher v2.8.27|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.27|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.26|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.25|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.24|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.23|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.22|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.21|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|remove symfony/yaml v2.8.27|install symfony/serializer v3.2.10|install symfony/serializer v3.2.11|install symfony/serializer v3.2.12|install symfony/serializer v3.2.13|install symfony/serializer v3.2.9|install symfony/serializer v3.3.8|install symfony/serializer v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.20|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.19|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.18|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.17|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.16|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.15|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.14|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.13|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.12|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.11|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.10|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.0-RC1|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.9|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.0-RC2|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.0-RC1|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.8|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.0-RC1|install symfony/event-dispatcher v3.2.0-RC2|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.0-RC1|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.7|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.0-RC1|install symfony/event-dispatcher v3.2.0-RC2|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.0-BETA1|install symfony/event-dispatcher v3.3.0-RC1|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1|don't install symfony/event-dispatcher v2.8.6|install symfony/event-dispatcher v3.2.0|install symfony/event-dispatcher v3.2.0-BETA1|install symfony/event-dispatcher v3.2.0-RC1|install symfony/event-dispatcher v3.2.0-RC2|install symfony/event-dispatcher v3.2.1|install symfony/event-dispatcher v3.2.10|install symfony/event-dispatcher v3.2.11|install symfony/event-dispatcher v3.2.12|install symfony/event-dispatcher v3.2.13|install symfony/event-dispatcher v3.2.2|install symfony/event-dispatcher v3.2.3|install symfony/event-dispatcher v3.2.4|install symfony/event-dispatcher v3.2.5|install symfony/event-dispatcher v3.2.6|install symfony/event-dispatcher v3.2.7|install symfony/event-dispatcher v3.2.8|install symfony/event-dispatcher v3.2.9|install symfony/event-dispatcher v3.3.0|install symfony/event-dispatcher v3.3.0-BETA1|install symfony/event-dispatcher v3.3.0-RC1|install symfony/event-dispatcher v3.3.1|install symfony/event-dispatcher v3.3.2|install symfony/event-dispatcher v3.3.3|install symfony/event-dispatcher v3.3.4|install symfony/event-dispatcher v3.3.5|install symfony/event-dispatcher v3.3.6|install symfony/event-dispatcher v3.3.7|install symfony/event-dispatcher v3.3.8|install symfony/event-dispatcher v3.3.9
    - Conclusion: don't install drupal/core 8.4.0-alpha1
    - Conclusion: don't install drupal/core 8.5.x-dev
    - Installation request for drush/drush ^8.1 -> satisfiable by drush/drush[8.1.0, 8.1.1, 8.1.10, 8.1.11, 8.1.12, 8.1.13, 8.1.14, 8.1.2, 8.1.3, 8.1.4, 8.1.5, 8.1.6, 8.1.7, 8.1.8, 8.1.9, 8.8.x-dev, 8.x-dev].
    - drupal/commerce 2.x-dev requires drupal/core ~8.4 -> satisfiable by drupal/core[8.4.0-alpha1, 8.4.0-beta1, 8.4.0-rc1, 8.4.0-rc2, 8.4.x-dev, 8.5.x-dev].
    - drupal/commerce 2.x-dev requires drupal/core ~8.4 -> satisfiable by drupal/core[8.4.0-alpha1, 8.4.0-beta1, 8.4.0-rc1, 8.4.0-rc2, 8.4.x-dev, 8.5.x-dev].
    - Conclusion: don't install drupal/core 8.4.x-dev
    - Installation request for drupal/commerce 2.x-dev -> satisfiable by drupal/commerce[2.x-dev].

What is going on ?

It worked before

  • The permissions? "directory is not writable" and also can you list your composer.json ? – Darrell Ulm Oct 4 '17 at 1:07
6

I think the relevant error is Your requirements could not be resolved to an installable set of packages.

I had this too when I tried to update to 8.4.

If you're trying to run Drupal 8.4 you will need to use Drush 9, not Drush 8.

Change the drush line to:

"drush/drush": "~9",

And try again.

P.S. It's better to run composer update drupal/core and composer update drupal/mymodule one-by-one than to run composer update by itself. composer update alone will update symfony dependencies before they have been tested for compatibility with core, which can break things.

0

I updated to Drupal 8.4 this way and that resolved composer requirement conflicts vis a vis Drupal and Drush, but Drush 9 was unable to recognize the running Drupal site as a running Drupal site:

 [error]  The command could not be executed successfully (returned: 

  [Exception]        
  Bootstrap failed.  

Now that https://github.com/drush-ops/drush/pull/2800 is in, dropping back to "drush/drush": "^8.0" worked for composer dependencies and for Drush to actually find the site.

0

Requirement : PHP 7.1
Explanation :
1. Doctrire, a dependancy of Drupal core, requires PHP 7.1. Doctrine uses the latest PHP 7.1 syntax to declare the methods' return type eg. function my_function() : void {...}
2. webflo breaks the chain of dependencies
3. Drupal 8.4 requires Drush 9.0

If you have PHP 7.1 on your server you can do the following:

  1. edit the composer.json file: "drupal/core": "~8.4" and "drush/drush": "~9.0"
  2. delete composer.lock
  3. delete vendor
  4. update webflo: composer require "webflo/drupal-finder ~1.0.0"
  5. update the database: ../vendor/bin/drush updb -y
  6. update the entities schemas: ../vendor/bin/drush entup -y

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.