If I allow users to comment while they are not logged in (anonymous authors), they will have a 'not verified' tag next to their name in the comments of my site. How can I remove it?

2 Answers 2


You can implement hook_preprocess_username and remove the extra variable:

function THEME_preprocess_username(&$variables) {
  $variables['extra'] = '';
  • This worked for me, but, I wondering if this will apply for all place in my site or only in comments?
    – Carlos
    Commented Apr 13, 2018 at 16:25
  • It will apply anywhere that uses the username theme to render that info @Carlos. Can’t really be more specific than that I’m afraid
    – Clive
    Commented Apr 13, 2018 at 16:42

It's also possible to change that in the backend.

Appearance » Settings » uncheck User verification status in comments in the Page Element Display section

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.