0

Problem

My content type has several fields and one of them is a field collection. Currently I have following issue: After adding and saving content everything is displayed fine. When editing, the contents of the field collection are all empty, but are saved in the database. After adding the same contents in the empty field collection and saving, when editing again the values are displayed.

So I do really not understand why this append, maybe someone can help me understand it and fix the bug.

P.S.: Please forgive my English (still learning).

1
  • Hey Kenorb, thank your for editing. It's make more sense :-)
    – Hermann
    Oct 24 '17 at 8:32
0

I've experienced this a while ago with field collections and paragraphs but can't remember the exact cause. Suggestions for troubleshooting:

  1. Check to make sure there's no updates available for the field collection module, Drupal Core, or any other modules that may be impacting the types of fields you're trying to assign in your field collection.
  2. If your field collection involves an entity reference to either:
    • another node and allows creation of said node within the edit form, make sure to click save on the embedded node creation form before saving the overarching node.
    • a file upload, make sure to upload the file before clicking save on the overarching node.

If this still doesn't work, try creating the field collection from scratch, adding one field at a time to determine which one is causing the issue.

3
  • Hey Anson, thank you for your reply. I will follow your suggestions and will let you know if this worked for me. Sincerely. Hermann
    – Hermann
    Oct 24 '17 at 8:31
  • I foud this: drupal.org/node/2828610, but I do not understand the meaning of this drush command. I know it perform a database update but what is the meaning of "-l myurl.pt" in "drush updb -l myurl.pt" ?
    – Hermann
    Oct 24 '17 at 9:01
  • So, now it's working. After updating the field_collection, entity and entity_translation modules.
    – Hermann
    Oct 24 '17 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.