-1

I am attempting to use a city location in the URL via pathauto. I have this for the URL [node:title]/[node:location:city:0]

When I create a new node, however, only the title is inserted into the URL.

Any ideas how to make this work?

0

Remember that token [node:location:city:?] is from location_node module, not from cck field. Did you created your own field with location in your node? In this case you have to enable location_entity module and using [node:field_mylocation:city:?] token.

|improve this answer|||||
  • I have tried using this token ([node:title]/[node:field_my_location:city:0]) but I always get the following error message when trying to save the setting: "Pattern for all test type paths is using the following invalid tokens: [node:field_my_location:city:0]". I even created a new test content type with the location field labeled "my location". – Finn Oct 26 '17 at 13:29
  • I was able to get this to work by using the field from the location_node module. When I attempt to use a (location) field I add to the content type, I cannot use a token. I get the invalid token error message when I attempt to use a token for an added location field. – Finn Oct 26 '17 at 17:30
  • Have you got enable location_entity module?? – lamp5 Oct 27 '17 at 7:14
  • I did enable the location_entity module. I still go the error message when attempting to add a token to a location field that I had added to the content type. – Finn Oct 27 '17 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.