0

I'm using:

  • Drupal 7
  • CKEditor 7.x-1.18
  • Jquery Update 7.x-3.0 (running jquery version 1.10)

I don't understand how to make the 'Font' & 'Size' dropdowns appear on the CkEditor interface.

  • The first image shows the settings for the "Full HTML" profile.
  • The second image shows the CkEditor in action. You can see that there are lots of buttons missing, but at the moment, I'm only interested in making the 'Font' & 'Size' dropdowns appear. You'll also notice that even though "Styles" hasn't been selected on the "Full" profile - it still appears here !?!?

I have been to the CKEditor site and downloaded the full package from here: http://ckeditor.com/download

The existing CKEditor install says to download, "Then uncompress the contents of the "ckeditor" directory of the downloaded file to this folder (modules/ckeditor/ckeditor)."

I appreciate similar questions have been asked before, but none of the solutions offered have worked for me.

Editing the Full HTML profile for CkEditor

pic 1 (above) Editing the Full HTML profile for CkEditor

Buttons are missing, and Styles has appeared pic 2 (above) Buttons are missing, and Styles has appeared !?

  • 1
    - Check if you have any JS errors in the browser console. Also, try to test if using the CDN version helps you, on /admin/config/content/ckeditor/editg -> ADVANCED SETTINGS -> //cdn.ckeditor.com/4.5.4/full-all – hugronaphor Nov 3 '17 at 19:54
0

Hugronaphor's comment helped me find a solution that worked for me... I'm just going to explain it clearly.

  • Browse to /admin/config/content/ckeditor
  • Edit the CKEditor GLOBAL Profile
  • Under the "Advanced Settings", change the "Path to CKEditor"

What you enter here will depend on whether you have downloaded and installed the full package (as described in my initial question) and where you have installed it, or whether you want to use the CDN. The instructions given below the text box are quite clear, but much like anything, it's just knowing where to look !

Because I'd already installed the full package and installed it to "modules/ckeditor/ckeditor" it means instead of using the CDN, I entered "%m/ckeditor" which made it work perfectly.

If I'd installed the full package to "/sites/all/libraries/ckeditor" I would have entered "%l/ckeditor"

...and if I wanted to use the CDN version, I would have entered "//cdn.ckeditor.com/4.4.3/full-all" Although, I assume this version number will possibly change in the future

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.