0

I'm using Drupal 8 and when I go to /admin/config/regional/content-language and try to turn on "Custom menu link", it doesn't save, and it just reloads unchecked.

I saw here that you need to check the actual items, as well, to get it to save, but that doesn't work either: https://www.drupal.org/forum/support/translations/2016-09-07/i-cant-save...

Then I realized that I can't save ANY changes to this page.

I see the warning "(* unsupported) Paragraphs fields do not support translation. See the online documentation.", which was red before I turned off translation for all Paragraph fields, and then the warning turned orange but remained. I had to go to the actual Content Type edit page to turn off translation from paragraph fields to get those changes to save.

Nothing is saving and I'm not seeing anything in the dblog. It just reloads as it was. I'm not even sure where to start on this. Any help would be greatly appreciated.

1

I tried the max_input_vars fix and that didnt work. I had to check the entity, pretend it was called MyCustomEntity in 'Custom language settings' at the top... but also scroll down to the individual MyCustomEntity settings further down on the page, and also check that checkbox. When I saved, now it worked

0

I don't know if I can help after all this time, but in my case the problem was the server php settings max_input_vars that was set to 1000 by default. After have increased that value to 5000, system returned to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.