0

I have a Drupal 7 dev-site hosted on pantheon. Using git bash and composer I installed drush on my windows 10 machine and I thought I did so globally. When I run composer --version and drush status I get what appear to be good responses. However, when I try to enable a module using drush or rebuild the registry I get ...

samha@LAPTOP-99SBTCQM /c/localworking/thecottagepress (master *=) $ drush 
@pantheon.thecottagepress.dev rr
/bin/bash: -c: line 0: unexpected EOF while looking for matching `''
/bin/bash: -c: line 1: syntax error: unexpected end of file

Here is what I get when I run drush status...

samha@LAPTOP-99SBTCQM /c/localworking/thecottagepress (master *=) $ drush 
status Drupal version         :  7.56
Site URI               :  http://default
PHP configuration      :  C:\PHP\php.ini
PHP OS                 :  WINNT
Drush script           :  
C:/LocalWorking/thecottagepress/vendor/drush/drush/drush.php
Drush version          :  8.1.15
Drush temp directory   :  C:\Users\samha\AppData\Local\Temp
Drush configuration    :
Drush alias files      :  C:/Users/samha/.drush/pantheon.aliases.drushrc.php
Drupal root            :  C:\LocalWorking\thecottagepress
Drupal Settings File   :  sites/default/settings.php
Site path              :  sites/default

What do I need to do to make drush fully functional? I have researched for most of today whith no luck. Thank you. Sam

0

If you are running drush on you're local site, you do not need to include @pantheon.thecottagepress.dev to run the command. Just run drush from your site root as so: drush rr. Drush won't be able to run the command on a remote machine if it can't resolve the domain name.

  • Blake, when I run drush rr I get..."The drush command 'rr' could not be found. Run 'drush cache-clear drush' to clear the commandfile cache if you have installed new extensions. [error]. Drush was not able to start (bootstrap) the Drupal database. [error]". When I run "drush cc drush" it succeeds. Then if I run drush rr again I get the same error as above. When I run drush @pantheon... rr I get the /bin/bash/ error again as stated in my original post. Thoughts? – Sam Nov 13 '17 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.