-3

I ran into the error described in this issue when uninstalling the google_fonts_api used by @font-your-face: https://www.drupal.org/node/2916712

I tried going through some manual uninstall steps for google_fonts_api and fontyourface. But now I'm stuck when trying to enable/disable other modules or clearing the cache with this recurring error:

exception 'Drupal\Component\Plugin\Exception\PluginNotFoundException' with message 'The "entity:font" plugin does not exist.' in                           [error]
/srv/bridgemojo.com/core/lib/Drupal/Component/Plugin/Discovery/DiscoveryTrait.php:52
Stack trace:
#0 /srv/bridgemojo.com/core/lib/Drupal/Component/Plugin/Discovery/DiscoveryCachedTrait.php(25):
Drupal\Core\Plugin\DefaultPluginManager->doGetDefinition(Array, 'entity:font', true)
#1 /srv/bridgemojo.com/core/lib/Drupal/Core/Plugin/Factory/ContainerFactory.php(16): Drupal\Core\Plugin\DefaultPluginManager->getDefinition('entity:font')
#2 /srv/bridgemojo.com/core/lib/Drupal/Component/Plugin/PluginManagerBase.php(84):
[...]

I've tried truncating the cache tables. I'm stuck with trying to manually remove any references to this plugin.

If there's no successful cleanup possible, I'll have to rebuild the site from scratch, but I'm afraid I'll lose all of the content I have created.

  • 1
    It looks like you're already getting support in the linked issue; I would try what they suggest. In general, the answer to a question like this is "always make a full site backup before a module install/uninstall." – Patrick Kenny Nov 14 '17 at 6:05
0

For others who might land on this problem, I gave up on solving it, and rebuilt my site from scratch. Luckily it wasn't a major effort.

0

I stumbled upon the same issue and solved it with these commands:

reinstall via composer require drupal/fontyourface, but do not enable it

drush config-delete views.view.fontyourface_font_manager
drush config-delete taxonomy.vocabulary.font_classification
drush config-delete taxonomy.vocabulary.font_designer
drush config-delete taxonomy.vocabulary.font_foundry
drush config-delete taxonomy.vocabulary.font_tags

see if other settings by a drush config-edit hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.