0

When I go to /admin/config/development/configuration/full/export and want to export the full archive, the site loads for a while and then just goes completely blank and the URL bar shows /admin/config/development/configuration/full/export-download.

There is no error in the server log files and no entry in the Drupal reports.

In the sync directory sites\default\files\config_[...]\sync there is no file except for the .htaccess.

And when I try drush cex or drush cex sync this error occurs:

PHP Fatal error:  Declaration of Drush\Command\DrushInputAdapter::hasParameterOption($values) must be compatible with Symfony\Component\Console\Input\InputInterface::hasParameterOption($values, $onlyParams = false) in C:\Program Files (x86)\DevDesktop\tools\vendor\drush\drush\lib\Drush\Command\DrushInputAdapter.php on line 27

I've tried everything with the settings.local.php enabled and disabled. But the export just doesn't work. What can I do?

1
  • probably outdated drush or too new php version....just guessing.
    – user21641
    Nov 14, 2017 at 23:22

1 Answer 1

1

Firstly, What is the version of drush?

I advise that you use the console bundle(add it via composer: "drupal/console": "~1.0")

and then execute this command

drupal config:export  --directory="modules/custom/import_export_config/config/install/"
1
  • I installed the console with composer require drupal/console:~1.0 --prefer-dist --optimize-autoloader --sort-packages but then when I run drupal list I get Fatal error: Uncaught Error: Call to undefined method Drupal\Console\Core\Utils\DrupalFinder::getVendorDir() in vendor\drupal\console-core\src\Utils\DrupalFinder.php on line 41
    – elterr1ble
    Nov 15, 2017 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.