0

In order to install MailChimp in Drupal 8 I followed the instructions for the MailChimp Drupal module.

Instructions for 8.x-1.x

The 8.x-1.x release uses version 3.0 of the MailChimp API and bundles the library with the module. This is a temporary solution until the process for installing libraries via composer is finalized in Drupal 8.

  1. in admin/modules/install I added mailchimp 8.x-1.3
  2. Checked that libraries is installed (Machine name: libraries; Version: 8.x-3.x-dev)
  3. Enabled all four modules (mailchimp, mailchimp_campaign, mailchimp_lists, mailchimp_signup)

However, when trying to configure the module at admin/config/services/mailchimp the page could not be found.

How can I resolve this issue and where should I start looking?

  • PHP 7.1.6-nmm1
  • Drupal 8.4.0-dev
0

You should use Composer to fetch this module, as it has an external dependency noted in its composer.json file:

http://cgit.drupalcode.org/mailchimp/tree/composer.json

It seems to include an older version with the module, I'm not sure why, but the current version of Mailchimp API by Thinkshout looks to be 1.0.8. I don't see any installation notes. The module comes with 1.0.6... ?

Other than that, clear your caches and try to access the page again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.