3

I have written custom code that creates a new action for Views Bulk Operations (VBO). I am trying to run the action and it gets stuck at "Prepared 46748 out of 46766". If I run the same action with 25 or 100 records it works perfectly.

Code has been changed but not that directly impacts this process. I do not know what code causes the regression and too many changes have been made to go back one commit at a time.

There is nothing Watchdog related to this process.

A little more on the custom action. The custom action adds the nid for each node to a queue to be processed fully over many cron jobs. I think the issue stems from the fact that every time a node is prepared by VBO it does a node save but I do not know what is happening to be sure.

I am looking for advice on how to troubleshoot this scenario and find a solution.

  • 1
    I hesitate to post this as an actual answer (I might convert this comment if it helps), but I'd try to (temporary) increase the available memory with like 10 or 25%, and see if you get past that nr of 46748 (possibly even past 46766). If it doesn't help, it won't hurt ... – Pierre.Vriens Nov 20 '17 at 8:36
  • That has done the trick. I just wish there was a way to see that in the logs. – Josh Nov 21 '17 at 16:29
  • merci for the feedback, refer to my (converted) answer for some more tips to get you going. – Pierre.Vriens Nov 21 '17 at 16:49
0

Try to (temporary) increase the available memory with like 10 or 25%, and see if you get past that nr of 46748 (possibly even past 46766). If it doesn't help, it won't hurt ...

BTW, even though this question is not about using Rules in combination with VBO, you might want to also watch the video about "More details about VBO settings" (especially what is explained between (about 04:00 and 05:00). It provides some extra hints / tips to process like 100.000 nodes at once, which is quite a challenge to get to work (memory requirements, etc).

  • How did you figure out the issue is with memory? I do not see any error messages. – giorgio79 Mar 2 '18 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.