2

Drupal 8.4 requires php version greater than 7.1 . In acquia devdesktop default we are getting php 7.0. How to upgrade php 7.0 to php 7.1 in Acquia dev desktop?

Thank you.

  • 1
    Drupal 8.4 does not require PHP 7.1 unless the requirements page is wrong: drupal.org/docs/8/system-requirements/php – Patrick Kenny Nov 27 '17 at 10:04
  • 2
    @PatrickKenny If you use Composer, a Doctrine dependency forces the 7.1 requirement (see docs.acquia.com/dev-desktop/known-issues) – Clive Nov 27 '17 at 10:20
  • 2
    You can manually require doctrine/annotations:1.4 To get it working again – mvdgun Nov 27 '17 at 10:53
  • @Gun5m0k3 How to do that? I have php 7.0. I am running this composer create-project markaspot/mark-a-spot project-dir --stability dev and getting error doctrine/annotations v1.6.0 requires php ^7.1. – Umair Mar 9 '18 at 14:57
  • Upgrade your DevDesktop, it now support PHP 7.1 – mvdgun Mar 9 '18 at 15:32
3

DevDesktop 2 now supports PHP 7.1.

Updated components in the latest version:

  • Added option to use PHP 7.1
  • MySQL Windows build) updated to 5.6
  • Percona (Mac build) updated to 5.6
  • Drush updated to 8.1.15
  • In addition, the feedback submission function within the app has been fixed.
  • I am using devdesktop2. It does not have 7.1. Only 7.0 – Umair Mar 9 '18 at 14:37
2

You can't at the moment. It's in Dev Desktop's known issues

  • Incompatible with Drupal 8.4.0 and greater

    The following issues affect attempts to use Drupal 8.4.0 and greater with Acquia Dev Desktop:

    • Acquia Dev Desktop includes Drush version 8.1.10, but does not include Drush version 8.1.14 (which is required by Drupal versions 8.4.0 and greater).
    • If you execute composer update for a website, Composer will also attempt to update the Doctrine library to a version that requires PHP 7.1, which is incompatible with Acquia Dev Desktop.
  • Incompatible with PHP 7.1

    Acquia Dev Desktop includes PHP version 7.0, but does not include PHP 7.1.

1

It is possible to continue to use Acquia Dev Desktop with Drupal 8.4. It doesn't require PHP 7.1, and can run in the PHP 7.0 within Dev Desktop. The real issue is the bundled version of Drush. Assuming you're on a Mac, make sure you have a brew install of Composer running on your machine. For more on that go here:

https://pilsniak.com/install-composer-mac-os/

Once that's done all you need to do is go here:

/Applications/DevDesktop/tools/

Edit the composer.json file within there, and update the drush version to the one below:

{
    "require": {
        "drush/drush": "8.1.15"
    }
}

Once you save that run a composer update and you should be good to go.

The alternate route is to require drush in your project's composer.json file which is a simple

composer require drush/drush
1

It's true. DevDesktop 2 now supports PHP 7.1

You must to update to the latest version (December 2017). I do not know why, but from the DevDesktop panel it did not give this update. Also I was still using the April 2017 version.

  • It's apparently a known bug. I saw the same thing, where the update listed no new updates. Being that I'm involved in the Drupal community, and work with many members of the Acquia team, part of the neglect may be due to plans for an entirely new successor to Dev Desktop. – karolus Apr 21 '18 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.