1

When I run...

composer global require drush/drush:dev-master

...I get...

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Can only install one of: consolidation/output-formatters[3.1.12, 2.1.3].
    - Can only install one of: consolidation/output-formatters[3.1.12, 2.1.3].
    - Can only install one of: consolidation/output-formatters[3.1.12, 2.1.3].
    - drush/drush dev-master requires consolidation/output-formatters ^3.1.12 -> satisfiable by consolidation/output-formatters[3.1.12].
    - Installation request for drush/drush dev-master -> satisfiable by drush/drush[dev-master].
    - Installation request for consolidation/output-formatters (locked at 2.1.3) -> satisfiable by consolidation/output-formatters[2.1.3].

My PHP version is 5.6.11.

3

The solution in my case was to run...

composer global update
composer global require drush/drush:dev-master

Previously, I had been running composer update but needed to run composer global update.

0

Assuming this is a Drupal 8 question; The recommended method of installing Drush is to now install it as a dependency of your project, not a system application.

composer require drush/drush

This will of course install Drush 9. If for some reason you need Drush 8 then other methods are available. But really not having to get the sysadmin involved in order to upgrade Drush is a relief.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.