0

By browsing my website in Drupal, I can browse perfectly through all the sections. The website has 3 languages. For Spanish, I can navigate well. For English, I can navigate well

But any page I try to access in Portuguese, redirects me to "core / install.php"

I have cleaned cache, I have reviewed everything, and it only happens to me when I change or try to navigate in Portugues.

Because it can be? Drupal version: 8.3.7 Drush version: 9.0-dev-g105e0aa

  • Do you have the correct settings in the language settings in the admin-menu (/admin/config/regional/language)? Where have you configured the language-switcher? and how is the language-switcher set up? seems as a problem somewhere there, but without the code it's difficult to help. never heard about problems like this. – btemperli Dec 15 '17 at 8:22
  • The website has been working with 3 languages for more than 6 months. The regional and language settings are correct (as it was more than 6 months ago). I do not know if the problem is because of a failed Core update or half. – Javier Dec 15 '17 at 9:02
  • This is the message that I get when I select any node in Portuguese of the Site: Drupal 8.3.7 Drupal is already installed To start again, you must clean up your existing database and copy default.settings.php to settings.php. To update an existing installation, proceed to update script. See your existing site – Javier Dec 15 '17 at 9:09
  • Thanks for the background-informations. Could be a problem of the failed update. The error-message you get on the install-page is the default message when you want to install a drupal-system over an already existing and installed system. I think the error is somewhere in the language-switcher: the wrong url is given for switching to portuguese language. – btemperli Dec 15 '17 at 9:51
-1

Increase the size of max_allowed_packet = 16M in the my.cnf file of mysql

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.