0

I'm working on a views to show different events in a calendar. I want to be able to filter on terms (In my view the field is called 'Wat?' for terms like music, art, design, etc). For this I create a filter criteria with an exposed filter for these taxonomy terms.

When I filter on film, only the film items are shown, perfect!

But now I want to make a complex filter by using filter groups. In both groups I want to use this genre filter. So I add another one. But for some reason this doesn't work, when I select film on both dropdowns and click apply it doesn't work anymore, and no results are given. I created a simplified view to test this. Here are images of my filter, and the use of it.

This is my complex filter

Using one filter gives results

But when selecting the film in both I get no result

0

The problem of my above question is a core bug. I added it to the Drupal Core issues, hope it will be solved soon. https://www.drupal.org/project/drupal/issues/2935113

In the mean time I found a work around. I use two different filters in the two added groups. Both filter on the same thing.

So in group 2, I filter on my Wat? field.

In group 3, I filter with the 'Has taxonomy filter'.

Both filter on the same taxonomy term but because they are different filters it does work now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.