5

We have added some drush aliases for a multi-site project, the aliases were converted from the previous syntax to the Drush 9 syntax (.yml files).

I went over the documentation, and also saw the previous issues, notes and changes on this GitHub issue.

For some reason the aliases didn't work inside $ROOT/../drush/sites as documented, but did work inside $ROOT/drush/sites, and I also had to use the format of [site].alias.yml and not [site].site.yml as on the documentation.

Another thing is that @greg-1-anderson wrote on his comment that

Only ~/.drush/sites et. al. are searched now.

So now I am really lost between the documentation, the comments, and the aliases that worked last week and were broken now after composer install.

Can someone please tell me what am I missing here?

** I've also tried to place the aliases in ~/.drush/sites/ (which didn't work).

7

Drush has undergone some change in behavior to simplify the implementation and increase maintainability ahead of the stable release.

  • Rename [site].alias.yml aliases to [site].site.yml
  • Spit apart [sites].aliases.yml (no longer supported) into multiple [site].site.yml files
  • Run drush init if you would like to maintain global alias files.

If $ROOT/../drush/sites is not working, perhaps you do not have a Composer-managed site. The actual supported locations for aliases is __DRUPAL_ROOT__/drush/sites and __PROJECT_ROOT__/drush/sites. The project root is where the composer.json file is located, which is usually at $ROOT/... It might be clearer if the documentation were updated to describe the supported locations in terms of the Drupal root and Project root, as this is now the basis for finding these directories.

  • That is so weird.. Now after I renamed all the .yml files to that format it worked, although this is exactly what I did in the morning (maybe I had a typo or something). $ROOT/../drush/sites still isn't working for me. What is $ROOT? Your meaning of $ROOT is the site root and not Drupal's root? (In the beginning I've tried to place the drush directory above the docroot = one above Drupal's root and where the composer.json is) BTW, I'm wondering why it worked last week, did you make any changes in the last few days? – rreiss Dec 27 '17 at 19:30
  • I don't know exactly what causes this problem, and don't know how to reproduce, but it seems that the aliases break from time to time after composer install / update. Am I the only one who's experiencing those issues? – rreiss Apr 25 '18 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.