0

I run a Drupal 7 website and have a separate WordPress blog. The blog generates a feed, which I display (RSS2 version) in a Block on the Drupal website via the Aggregator core module. This worked fine until somewhere in December.

The last update post/feed shown on the Drupal website is from 24 Nov. '17. The newer 2 posts have not made it onto my Drupal website. However, when I check the feed itself, the posts are present in the feed.

Drupal website: https://www.lovedominique.co.za/

Feed of blog: https://lovedominique.co.za/blog/feed/

The error message that Drupal shows is:

The feed from New On Our Blog seems to be broken, due to an error "Invalid document end" on line 128.

I checked the feed on http://www.feedvalidator.org/ (link). There is no mention of line 128 on feedvalidator. But, another error shows up for line 187:

line 187, column 0: url must be a full URL: https://lovedominique.co.za/blog/wp-content/uploads/2017/10/adding_texture.mp4

I don't understand why I am getting these error messages. The lines look okay to me.

  • Installed updates
  • I deleted my browser's cache (Firefox ESR).
  • I deleted the Drupal cache (on the server).
  • I added a new test post to the blog, and confirmed that it shows on the feed (https://lovedominique.co.za/blog/feed/). Yet, it does not get imported by Aggregator.
0

It turns out that a simple smiley :) wrought all the havoc. The smiley was situated in the first paragraph of a post and was therefore transferred via the feed to Aggregator.

Removing the smiley removed the errors and now the feed is showing correctly again.

I don't know what exactly is wrong with ':)', but somehow it messed things up. Explanations are welcome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.