I have an issue when I try to add a translation of a taxonomy term using the site UI. The original language value changes to the translation value that I added.

How can I prevent that from happening?


You need to make sure it is translatable in the language settings.

Go to:


Make sure that taxonomy term is checked in the custom language settings. If not, check and save.

Then find the Taxonomy section in the form. In this section, make sure that your vocabulary and fields you want translatable are checked. Include the show language on edit option as well

Once you have done that, go to:


And create translations for the vocabulary for each language you want.

Also edit the vocabulary settings and make sure there is a default language specified for new terms.

Next, if you have existing terms, you need to edit the term and set a default language in the dropdown. E.g. english instead of not specified.

Once you do this, you will get a translate option on the edit / delete dropdown in the list. Select translate to add additional languages.


If you are using Entity Translation the path for this is a bit different.


This is what worked for me:

  1. Select Taxonomy as Translatable Entity
  2. Find your Taxonomy in the display below
  3. Pick Default language
  4. Uncheck "Hide language selector"
  5. Check "Exclude Language neutral from the available languages" Important for a variety of other reasons... SOLR and view queries for example
  6. Uncheck "Prevent language from being changed once the entity has been created"
  7. You could check/uncheck "Hide shared elements on translation forms" depending on your situation.

And then YES ... You will need to edit every term so it has a defined language (Default is English in my case)

Once All terms have been assigned a language they can be translated.


You have to enable Content Translation module, and select taxonomy vocabularies you want to be translated, and you will see translation buttons in every single fields/terms

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.