2

I am new to Drupal and am attempting to install pathauto. But when I click on "extend," I don't have a "install new module" button.

Any suggestions?

2
  • are you administrator ? what do you see if you visit admin/modules/install ? – GiorgosK Jan 17 '18 at 21:05
  • Thanks everyone.... I finally got it to work --when I followed the suggestion that I change the theme from Bartik to Seven. That added the install new module button. I have since switched back to Bartik and the module button is still there. Thanks for so quickly answering my question and helping out! I really appreciated it! – editor Jan 18 '18 at 14:15
4

You need to enable the core Update Manager module:

Checks for available updates, and can securely install or update modules and themes via a web interface.

Emphasis mine.

Also make sure the user you're logging in as has the Administer software updates permission granted. If it's user 1, you already have access.

2
  • When I hit "update manager module" at the top, it takes me down to the Core (experimental) modules. Are those the ones I am supposed to enable? Thanks again! – editor Jan 18 '18 at 0:16
  • There’s a module named Update Manager (not experimental), that’s the only thing you should have to enable – Clive Jan 18 '18 at 8:22
3

This drove me crazy till I figured it out. Goaddy techsupport is also pretty clueless.

Under Drupal 8.x this option is no longer accessible through the 'Appearance' menu.

Instead, you'll find it under: Reports menu >> Available Updates, as an: "+Install new module or theme" button.

(The breadcrumb will read: Home >> Administration >> Reports)

A side note: in the Reports, if you see any errors, such as opcache missing, you're advised to enable it from the PHP configuration page, and also enable Update manager in drupal.

Irony of ironies, once you've installed the new theme, from the appearance menu page, the "Install new theme" button starts displaying there. aargh.

1

Some possible causes for this issue (partially inspired by "Can't Find the "Install new module" Link in Drupal?)":

  • It could be a theme related issue. To check if that's the case, set "Seven" as the administration theme, and verify if that button shows up.

  • Some hosting companies won't allow you to upload modules via the Drupal interface. As an example, here is a quote from "Installing a Drupal module on Acquia Cloud":

    One of the most common tasks you'll accomplish while developing or maintaining a Drupal application is adding a Drupal contributed module. If you are used to working in a local installation of Drupal, you may be used to doing this directly in the Drupal admin interface, using the core Update Manager module, or perhaps with Drush, using the drush dl command. If your application is hosted on Acquia Cloud, the module directories are part of the code repository, which is not directly writable. This means that you can't directly add a module using the Update Manager, drush dl, or SFTP. Instead, you must commit your changes using a version control system (Git).

  • Check your settings.php file allows it, i.e. ensure it contains a line that looks something like this: $conf['allow_authorize_operations'] = TRUE; (or as a variation: #$conf['allow_authorize_operations'] = FALSE;, so make sure it is commented out, to not set to FALSE).

1
  • For Acquia, you can enable Live Development in non production environment and that should set you up. – mhijazi Mar 5 '18 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.